
SPU iTunes U - Frequently Asked Questions 
For general information on using iTunes U, please see our Quick Start guide. 
 
Getting Started 

• What is iTunes?  
iTunes is free media-player software than runs easily on a Windows PC or a 
Macintosh. Simple and easy to use, iTunes allows users to browse, play, download, 
and organize audio and video content. iTunes can be downloaded for free here. For 
installation assistance, click here. 
 

• I use Windows. Can I still use iTunes? 
Yes. iTunes exists for both Windows PCs and Macintosh computers. It is not 
necessary to own a Mac or be familiar with one in order to install and use iTunes.  
 

• How do I know if I have iTunes installed? 
To find out if you have iTunes installed on a Windows PC, click on the Start button, 
go to All Programs, and look for a folder called iTunes. If you see it, you have 
iTunes; otherwise, you must download it. For installation assistance, click here. All 
recent Macintosh computers come with iTunes. 

 
• What is iTunes U? 

iTunes U is a special feature in iTunes that allows users to browse and play Seattle 
Pacific content over the Internet through the iTunes program. Users can play content 
directly from the Internet, or download it to their computer and play it at a later time. 
Users can also put content onto CDs or personal media devices (such as Apple’s 
iPod) to play it away from their computer. For more information, go to 
www.itunesu.com.  

 
• Who can use iTunes U? 

Anyone with a computer and a broadband Internet connection can easily access 
iTunes University. (Because of the large file sizes, we do not recommend using 
iTunes U with a dial-up Internet connection.) iTunes U is thus fully open to the 
public; however, only members of the Seattle Pacific community can submit content 
to be posted in the Community section.  
 

• What is an iPod? What is a “personal media device?” Do I need one? 
Personal media devices are small electronic devices that can fit easily in a pocket and 
allow users to experience content on the go. The iPod is one of several such devices 
currently available. It is not necessary to own one in order to use iTunes U.  
 
If you have a personal media device, you can use it to play iTunes U content. To put 
content onto an iPod or other such device, download it to your computer from iTunes 
U using the Get (or Get Movie) button. If you own an iPod, you can transfer the 
content to it by connecting it to your computer while iTunes is open. See your iPod’s 
user documentation for more detailed instructions. Users of other devices should 
consult their device documentation. Note that the iPod is the only personal media 
device that can play iTunes U video. 
 

http://www.spu.edu/itunes/quickstart.asp
http://www.apple.com/itunes/download/
http://media.spu.edu:8888/p69567380/
http://www.apple.com/itunes/download/
http://media.spu.edu:8888/p69567380/
http://www.itunesu.com/


• I need help installing and using iTunes. Where do I go? 
Installation – We have created a full video walkthrough that takes you step-by-step 
through the installation process.  
 
General Use – Many general-use iTunes questions are covered in our Quick Start 
guide. Most other questions can be answered from the Help menu within iTunes 
itself.  
 
Troubleshooting – Issues specific to iTunes U that aren’t covered in this FAQ can be 
emailed to iTunes@spu.edu. General iTunes troubleshooting should be directed to the 
iTunes support site:  

Windows-PC support: http://www.apple.com/support/itunes/windows/. 
Macintosh support:  http://www.apple.com/support/itunes/. 
 

• I can see other people’s playlists in iTunes. Did someone hack into my 
computer?  
No. Public sharing is a standard feature in iTunes that allows anyone on your 
computer’s network to browse your music. For security reasons, we suggest you 
disable it by going to the Edit menu and clicking on Preferences. From there, click 
on the Sharing tab, which has an option to disable the feature.  
 

General Questions 
• How do I access iTunes U?  

To access iTunes U, click the iTunes U link on the SPU homepage (under Campus 
Resources), and then click the Open SPU on iTunes U >> button. iTunes U will 
open in a new window.  

 
• Can I search/access iTunes U through the iTunes general Music Store? 

No. Currently, the only way you can access iTunes U is through the SPU website. 
You can perform a search using iTunes but only after you have opened iTunes U. 
 

• How do I view information about a file? 
There are two ways to view information about a file. First, we recommend that all 
users tell iTunes to include track dates, synopses, etc. in the main window:  
 
 
 
 
 
To do this, right-click (Control-click for Macintosh) on the title of the Price column 
and click Comment from the popup menu. You may want to play with the width of 
your columns. For more information, see Step 3 of our Quick Start guide. 
 
You can also view all available information about an individual file in a separate 
window. To do this, right-click on a file (Control-click for Macintosh), click Get Info 
from the popup menu, and then click on the Info tab in the window that appears.  
 

• What is the Comment field? Why do I want to use it? How do I enable it?  
The Comment field is an extra column of information that you can make visible. It 
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contains information about each track, including its date, speaker/artist title, and, 
occasionally, a synopsis. Easy-to-follow directions for enabling it can be found in 
Step 3 of our Quick Start guide. 

 
• How do I perform a search? What do my results mean? 

To perform a search in iTunes U, type your search query into the search box in the 
upper-right corner of the iTunes window, and press Enter on your keyboard.  
 
 
 
Search results are displayed sorted by relevance. Note, however, that iTunes does not 
comprehend your search query. Instead, it searches the fields (Name, Artist, 
Comment, etc.) by exact word only. As a result, you may have to try several different 
keywords to find all the files related to the topic you wish to search. It may also return 
files with similar-sounding words. For example, a search for “Weter” may return files 
with “Peter” or “Writer.” These, however, will be marked with low-relevance status. 
 

• How do I navigate the iTunes U interface?  
For this and other introductory information, please see our Quick Start guide.   
 

• I can’t find what I’m looking for. Where is it? 
Content on iTunes U is divided into nine sections: 

o Campus Lectures & Forums: Includes public lectures and forums featuring 
speakers from the SPU community and special guests from around the world. 
Lectures include the Marston, Palmer, Walls, and Weter Lectures, Day of 
Common Learning, workshops, special events, and more.  

o Chapel: Come explore our diverse digital library of Chapel speakers and 
services dating back to 1970. Current and historical tracks will be added as 
they become available. 

o Group: Guest and community speakers from SPU’s weekly, contemporary 
evening worship service. Topics are usually thematic by quarter. 

o Falcon Sports: Falcon athletics have a long history at SPU. Experience events 
featuring falcon athletes, and join us as we celebrate inductees in the Falcon 
Legends Hall of Fame. 

o Convocations: Convocations are special University gatherings. This diverse 
category includes special ceremonies, academic celebrations, and addresses, 
and is a rich record of SPU’s vision and history. 

o Alumni Events: Browse special Alumni functions, such as Alumni of the 
Year Homecoming Chapels, Alumni of the Year Ceremonies, and the 
President’s Luncheons. 

o Course Lectures: Hear class lectures and other instructional material from 
the acclaimed SPU faculty across the disciplines. 

o The Arts: Explore audio and video artistic productions from students and 
faculty in the fine and performing arts.  

o Community: A place for independent content from members of the Seattle 
Pacific Community. If you are affiliated with the University (Faculty/Staff, 
Student, Alumni, etc.), we encourage you to submit content. 

 

http://www.spu.edu/itunes/quickstart.asp#3
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• What does the Get Tracks button do? 
Clicking on the Get Tracks button will automatically download all the tracks on the 
current tab to your computer. If you have accidentally clicked this button and want to 
cancel your downloads, enter the downloads area by clicking Downloads on the left 
side of the iTunes window. To cancel a download, click on it and press the Delete key 
on your keyboard. To delete all downloads (clear the list), go to the View menu at the 
top of the screen, click Select All, and then press the Delete key on your keyboard. 
 

• What is a podcast? What is a vodcast? 
A podcast is the audio equivalent of a magazine subscription, and a vodcast is a video 
podcast. Once you subscribe to an SPU podcast, iTunes will automatically download 
any new tracks in that section of the site to your computer as they become available. 
Once you have subscribed to a podcast, you can access it by clicking on Podcasts on 
the left side of the iTunes window.  
 
Podcasts can take up quite a bit of storage space on your computer, so we recommend 
that you periodically delete content that you no longer wish to keep—just like 
throwing out old magazines. You can edit podcast settings by clicking Preferences 
from the Edit menu. Because Apple regularly updates the podcasting features in 
iTunes, we have not provided a tutorial for downloading and using podcasts. Instead, 
please see the Help menu in iTunes for the most up-to-date information and 
directions.  
 

• What does the Subscribe button do? 
The Subscribe button signs-up your computer to receive the current tab as a podcast. 
A podcast is like a magazine subscription. See the previous question Step 5 of our 
Quick Start guide for more on podcasts. 
 

• When I download a track from iTunes U, is it added to my library? 
Downloaded tracks are added to your library, but they are not added to your 
Purchased Music list.  
 

• Can I access files that I’ve downloaded to my computer with other programs? 
How do I find those files? 
Yes. Once downloaded, tracks become part of your library and are stored on your 
computer. To find the location of any file in your library, right-click on it and click 
Get Info from the popup window. The file path is then given on the bottom of the 
Summary tab. Alternatively, you can create a copy of any file by clicking-and-
dragging the track from iTunes onto your desktop. This will create a copy of the 
original file on your desktop.  
 

• Is it true that I can use portable media devices other than an iPod to play iTunes 
U content?  
Yes, you may play audio on a device other than an iPod. Seattle Pacific University 
currently posts audio to iTunes U in a non-protected .mp3 file format, so any audio 
you download will work on most mainstream devices. However, because video is 
posted in an Apple proprietary format, it cannot be played on devices other than the 
iPod. See your device documentation for instructions on adding files. See the prior 
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question for the location of files downloaded to your computer from iTunes U.  
 

Troubleshooting 
• I tried to open iTunes U but was redirected to an iTunes website. What 

happened? 
This occurs when you try to open iTunes U but do not have iTunes installed. The 
page you were redirected to is the site from which you can download iTunes. You 
must download and install iTunes in order to use iTunes U. Fortunately, we have 
created a video tutorial to walk you through the process. 
 

• I downloaded a track but cannot find it in iTunes. Where is it? 
Downloaded tracks are added to your library, but they are not added to your 
Purchased Music list. To access downloaded audio files, click on Music on the left 
side of the iTunes window. To access downloaded videos, click Movies. 
 

• I can’t view videos downloaded through iTunes U in Windows Media Player or 
other software. Is there a way to do so?  
Unfortunately, no. Video files on iTunes U are in a proprietary Apple format, so only 
Apple computers, Apple software (such as iTunes), and Apple hardware (such as 
iPods) can play them. However, we do post audio versions of all videos on iTunes U 
to increase accessibility. 
  

• Video quality seems sub-par when displayed full-screen. How can I get higher-
quality videos of specific events? 
Because of the immense file size associated with video, we only post low-resolution 
videos on iTunes U. However, we would be happy to furnish you with a DVD of a 
specific event for a minimal charge. To request a DVD copy of an event, stop by the 
ITS office on the lower level of the SPU Library during normal business hours, or 
email us at its@spu.edu. 
 

• I have an iTunes U question not answered here. Where do I go for help? 
For help with general iTunes issues, see one of the links below or see the Help menu 
within iTunes itself. For help with iTunes U issues, please send an email to 
iTunes@spu.edu. You can also visit the ITS office on the lower level of the SPU 
Library during normal business hours.  
 

• For more Windows iTunes support, visit 
http://www.apple.com/support/itunes/windows/.  
 

• For more Macintosh iTunes support, visit http://www.apple.com/support/itunes/ 
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